Before posting, please read: When to use this forum, when to submit a help ticket

Audio playback on BandHelper web version

Started by Troubador, March 27, 2018, 05:35:54 PM

Previous topic - Next topic



It's taken me a while to set up my BandHelper Repertoire. I now have it all set - all my (current) songs are listed and each one has a PDF (lyrics/chords) and an .mp3 (or .aac) file attached.

When I try to play the audio recording (iMac/OS 10.13.3, Firefox 59.0.1/64-bit) - screenshot attached - nothing plays through the computer. What I mean to say is that if I click the "Play" button, nothing happens.

If I try the same thing on my iPad (1G) or iPhone, the audio playback works.

Is there something else that I need to do for the playback on my iMac?




If you try a different browser does it work?

If you click the Edit button next to a recording, does the recording file appear there with a download button, or does it show "no file uploaded"?


If I click the Edit button, it shows the track (the tracks are there since they play on my iPad and iPhone).

I just tried it in Safari and it plays in Safari ... so I guess the problem is with Firefox.

OK. Thanks. At least I know what the problem is -- my favourite browser!! :)

Thanks for the help.


I just tried in Firefox on my Mac and the audio player wants to use Flash, which Firefox was blocking by default. When I allowed Flash for, the recording played. Does that help?


Ahh ... maybe it needs Flash to run. But I keep Flash off my computer ... well, at least we know the reasons that audio won't play in Firefox!

Thank you.


It doesn't use Flash in other browsers, but Firefox prompted me to use that. I can look into why Firefox did that and try to force it to use HTML5 instead.

Meanwhile, you could click the download button for a recording and then it should download and play from a local audio app (probably QuickTime Player on a Mac).


Thanks. Not sure if you know this, but clicking on the 'download' icon leads me to an error page - screenshot attached.

I thought you might want to know ...


Which download button? I don't see a problem if I use the one in the recording toolbar or the one on the recording edit page.


I've marked the button - it's to the far right, beyond the volume icon.


Okay, that's working for me, but I'll check it again when I look into the Flash issue.


I just made a tweak that should bypass Flash. Does that help?

I still don't see a problem with the download button.