Before posting, please read: When to use this forum, when to submit a help ticket

Author Topic: Midi clock not showing programmed tempo  (Read 276 times)

wakevortex

  • Senior Member
  • ****
  • Posts: 81
  • Karma: +1/-0
Midi clock not showing programmed tempo
« on: May 10, 2018, 11:54:20 AM »
Hi there

Using the line 6 HELIX I’m trying to send midi clock from band helper  to set delays etc
I have set each song correctly in bandhelper  , but the helix is NOT showing the right tempo..
At settings  of slow tempos, around 70 say, it shows on the helix at 74 or 75 , if the tempo is 120 it’s about 130 or 131 on the helix...
Any ideas why the clock is received by the helix but not at correct tempo?

Thanks

B Padley

arlo

  • Administrator
  • Senior Member
  • *****
  • Posts: 3560
  • Karma: +82/-3
Re: Midi clock not showing programmed tempo
« Reply #1 on: May 11, 2018, 09:34:09 AM »
iOS or Android?

Please see this existing thread for iOS: http://forum.arlomedia.com/index.php/topic,1484.msg5665.html#msg5665

wakevortex

  • Senior Member
  • ****
  • Posts: 81
  • Karma: +1/-0
Re: Midi clock not showing programmed tempo
« Reply #2 on: May 11, 2018, 09:50:11 AM »
Hi Arlo

Thanks for the  link...its IOS 11 on an IPAD pro using a yamaha MD-BT01 to receive midi at the Line 6 Helix
Here are some examples of SONG tempo set  in Bandhelper vs what arrives in Helix, and it runs at when clocked by the band helper midi clock

also the light on the helix which flashes in time, is VERY irregular under bandhelper midi clock   

BH       HELIX
65       69
76       80
80       82
113    127
121    135


as you can see they are all over the place ......  any ideas?

EDIT

just tried sending Midi clock from MIDIFLOW app on IOS...same thing ! ...so it looks like the HELIX is misinterpreting the incoming midi clock tempo....bizarre!
Unless you have any brainwaves, will open a thread on Helix forum to see what they say

Thanks again

Bill P
« Last Edit: May 11, 2018, 09:55:27 AM by wakevortex »

arlo

  • Administrator
  • Senior Member
  • *****
  • Posts: 3560
  • Karma: +82/-3
Re: Midi clock not showing programmed tempo
« Reply #3 on: May 11, 2018, 12:20:39 PM »
The current state of affairs on iOS 11 is that the beats come about 2 ms too fast until the 15th beat, which comes 30 ms slower as a correction. So the overall tempo over time should be correct. I believe this is a bug in iOS, which I've filed with Apple, but they haven't offered any solutions yet.

At 120 bpm, a 2 ms variance would change the tempo by less than 1 bpm, not the 4+ bpm changes you're seeing.

I have seen variations of up to 5 bpm when using the MD-BT01, but those are blips, not consistent. Anyway, you might try with a wired MIDI connection to see if that helps.

wakevortex

  • Senior Member
  • ****
  • Posts: 81
  • Karma: +1/-0
Re: Midi clock not showing programmed tempo
« Reply #4 on: May 11, 2018, 12:31:12 PM »
Thanks Arlo......reluctant to add yet another wire :-)  but will try it with the camera connection from iPad  and see if it makes any difference....

bizarre...surely 120 bpm is 120 bpm....its maths?

also will report back if any helix users mention a solution

thanks again

Bill P



pheldal

  • Senior Member
  • ****
  • Posts: 93
  • Karma: +1/-0
Re: Midi clock not showing programmed tempo
« Reply #5 on: May 12, 2018, 05:45:54 AM »
I'm also struggling a bit with tempo on my Android tablets, but I don't know if it is related to this. I don't use the tempo externally though, only a blinking tempo icon on the screen I use for setting tempo for songs where I start alone with some form of intro. The blinking of the icon seem to vary by almost +/-10 bpm.  A blinking background does not perform any better, and is also too much of a distraction.

arlo

  • Administrator
  • Senior Member
  • *****
  • Posts: 3560
  • Karma: +82/-3
Re: Midi clock not showing programmed tempo
« Reply #6 on: May 14, 2018, 09:12:26 AM »
The visual flash in Android is a different problem than the MIDI output in iOS. This might be improved in the next version ... needs more testing.