Before posting, please read: When to use this forum, when to submit a help ticket

Help with playing both a video and an audio recording

Started by WashedUp, March 04, 2019, 05:59:56 AM

Previous topic - Next topic


I'm just not sure how to get them to play together. I don't see how one can attach a video to a recording similar to attaching a mid file to a recording.

And, if I play the audio then start the video either manually or via automation, the audio stops playing.

In a perfect world I would like them to play together in sync.

Please point me in the right direction.


I just attached a video and an audio recording to the same song and I was able to play them simultaneously on an iPad with iOS 12.1 and an Android tablet with Android 8.1. What setup did you try?


I'm on an Ipad pro 12.1 

Recording uploaded as just that, a recording.

Video uploaded as a document.


Can you use another device to take a video showing what you're doing?


Thanks. That's obviously not right; please submit a help ticket so I can dig into your settings:


I got your settings. I've never seen the recording do what it's doing in your video. I mimiced all your settings and am using the same iOS version and it's working perfectly for me.

Did you already try restarting your device?

The only other suggestion I can think of is to send me the two files you're testing with and I'll try it with your files. You can attach those to the help ticket you already opened.


Ok, files are sent.

Something new I've observed;  If I open the document (video) first, I can get them both to play using the small control, as opposed to the larger play arrow as shown in the video in this post.


Okay, I was able to reproduce the problem with your files. The problem seems to be with the video, not the audio file, because the problem occurs when I pair the video with any other audio file, but it doesn't occur when I pair the audio file with some of my videos. However, it does occur with some other of my videos.

It seems that when some videos load, they reset the iOS audio engine and unload the recording. I tried changing the sequence so the video starts first, then the recording starts, but that didn't help because it takes longer for the video to load.

One way you could work around this is to record an automation track for each song that starts the video, then 2-3 seconds later starts the recording. Then when you select a song, start the automation track rather than starting the video and recording separately.

Alternatively, you can turn on Help > Utilities > Use Old Audio Engine and then the video won't interfere with the recording. With the old audio engine, tempo clicks won't be as accurate and you won't be able to use multi-route output or inter-app audio.


Thanks for checking!  Do you think I could change something in the rendering of the video to make it compatible?

Just a thought.


Yes, because some videos trigger this problem and some don't. But I looked at a few videos of each and couldn't see any common pattern.

One thing you could try is exporting the video without an audio track, since you aren't using the videos for audio.


Right, actually the video I sent I believe has no audio. (at least I had the audio track muted at render)

I wonder if anyone could send me a video that does work properly, so I could investigate?

Now that I think about it, perhaps it's a conflict of sampling rate with video normally be at 48 for it's audio, and I know my mp3 is at 44.
Seems like the first place to look....


Solved!  I re-rendered the video choosing no audio (as opposed to muting the audio track) and it works as expected.

Also rendered with audio choosing 44.1 and that works as well, except for the obvious clutter of two audio tracks playing together lol.

I did not test automating the play times to have them both start together to see how close the audio would sync up, assuming that it would be unlikely to have no phasing issues.

Now we know! Thanks for your time and leading me down the right path.


Ah, yes. With the videos I tried, the one that worked used a 44.1 sampling rate and the one that didn't used 22.05, while yours used 48. So it appears that the video and audio files must use the same sampling rate if you want to start the video at the same time or after starting the audio. I can report this as a bug to Apple.