Before posting, please read: When to use this forum, when to submit a help ticket

Author Topic: Midi question  (Read 2056 times)

Neill00

  • Senior Member
  • ****
  • Posts: 71
  • Karma: +1/-0
Midi question
« on: January 23, 2020, 04:50:19 AM »
I use remote control functions “scroll document up” and scroll document down” (among others) but I find it behaves differently if I use Midi CC to activate or midi note numbers to activate.   Midi note numbers is far more accurate and predictable, whereas the CC can jump more than expected and only goes to a certain minimum when you sent the percentage which the lowest you can set it is 5%.  5% in CC is a bigger jump and 35% in midi note number.  IS this because it’s reacting to the note off as well?

arlo

  • Administrator
  • Senior Member
  • *****
  • Posts: 4680
  • Karma: +108/-3
Re: Midi question
« Reply #1 on: January 23, 2020, 08:45:02 AM »
I don't think the Note Off would matter. Can you click the MIDI icon in the top toolbar and watch the MIDI activity log while you do this to get a better idea of what's happening?

Neill00

  • Senior Member
  • ****
  • Posts: 71
  • Karma: +1/-0
Re: Midi question
« Reply #2 on: January 23, 2020, 08:09:34 PM »
At my next opportunity I’ll do run them both ways and capture the midi activity for each.

Neill00

  • Senior Member
  • ****
  • Posts: 71
  • Karma: +1/-0
Re: Midi question
« Reply #3 on: January 25, 2020, 08:58:12 AM »
I used irig blueboard to trigger.  Each method Button A once for scroll document up and Button B once for scroll document down using each method.  The first image is using note numbers in midi bluetooth mode 1.  The next 3 photos show the exact same thing one press each for the standard mode using CC.

arlo

  • Administrator
  • Senior Member
  • *****
  • Posts: 4680
  • Karma: +108/-3
Re: Midi question
« Reply #4 on: January 26, 2020, 08:35:44 AM »
The MIDI log shows that you're receiving a MIDI CC message on every channel. If you're responding to all those, you would get 16 actions for each button press. You can either change the Blueboard settings to only send on one channel, or in BandHelper, change Settings > Remote Control > MIDI Input Channel to a single channel. You can also look at the remote control status window (foot switch icon in the top toolbar) to see which actions are actually getting triggered by these messages.

Neill00

  • Senior Member
  • ****
  • Posts: 71
  • Karma: +1/-0
Re: Midi question
« Reply #5 on: January 30, 2020, 03:45:00 AM »
Thanks Arlo, I’ll try some of those ideas I’m sure just reducing to one channel in either BlueBoard or bandhelper will likely fix the problem.