Before posting, please read: When to use this forum, when to submit a help ticket

Author Topic: Automation overdub disables playback of a recording  (Read 6186 times)

Pongo

  • Senior Member
  • ****
  • Posts: 244
  • Karma: +4/-2
Automation overdub disables playback of a recording
« on: July 30, 2014, 08:00:26 PM »
Hi Arlo,

Ok, here's the GOOD news: Since the automation event log is showing `Recording Start/Stop' as opposed to how is was before, for reasons unknown `Play Recording [name of recording], this means that I can still edit my songs that have multiple recordings attached, to prioritize the `version' that I need for that performance. This is a very good thing, IMHO, since the automation will play the first recording associated with the song. If possible, please don't change that feature! LOL!

Now...the issue that I'm having is during an automation overdub. The first event in the log is `Recording Start/Stop', and when I try to record a second layer of automation, the recording stops. This makes it impossible to make any additions to the automation, since I need to hear the recording. Did you build SLM 4.0.4 to work this way...meaning that if I select `Record' from the automation menu, even after the timing of an event has passed (Recording Start/Stop is @ 0.00), the recording is turned OFF*,?

My thoughts are that I will need to delete this Recording Start/Stop event and temporarily enable the song selection action to play the recording. This should allow me to record and overdub automation without the recording being turned off. If that works, my last step would be to then disable the song selection action and record a new Recording Start/Stop event and adjust the timing to be as close to 0.00 as it needs to be to align with how the song selection action worked.

Does that seem logical, or is this (*) an issue that needs to be looked at on your end?

Thanks,

arlo

  • Administrator
  • Senior Member
  • *****
  • Posts: 4605
  • Karma: +107/-3
Re: Automation overdub disables playback of a recording
« Reply #1 on: July 30, 2014, 10:01:52 PM »
Now...the issue that I'm having is during an automation overdub. The first event in the log is `Recording Start/Stop', and when I try to record a second layer of automation, the recording stops. This makes it impossible to make any additions to the automation, since I need to hear the recording. Did you build SLM 4.0.4 to work this way...meaning that if I select `Record' from the automation menu, even after the timing of an event has passed (Recording Start/Stop is @ 0.00), the recording is turned OFF*,?

Recording Start/Stop is a toggle, meaning if the audio recording is playing, it will stop, and if the audio recording is not playing, it will start. Are you manually starting the audio playback before you start recording the automation track? You shouldn't do that -- just let the previously recorded automation events start it.

By the way, you're still talking about the timing of events in an automation track as if they are measured from some event outside the automation track, like when you select the song or something. But all events are measured from the when the automation track starts recording or playing. So your comment about recording new events "after the timing of an event has passed" is misleading. Until you start recording the automation track, no timing is happening.

Pongo

  • Senior Member
  • ****
  • Posts: 244
  • Karma: +4/-2
Re: Automation overdub disables playback of a recording
« Reply #2 on: July 30, 2014, 10:23:19 PM »
No. I am not manually starting the audio playback. It is the first event in the EXISTING automation track and hits at 0.00
I also understand that the Recording Start/Stop command is a toggle. I get it. `light on' `light off'.

In one of our previous discussions, you suggested that I disable the Song Select Action to play a recording (as I had done in V3.4) and start using an automation event (at the start of the song) to play the recording, so that any overdubs would be aligned with the recording...which is what I did.

I don't know how to make this any clearer; I know that the Recording Start/Stop `event' has passed in the existing automation track, when I hear the recording playing, which is when I attempt to record additional automation events! Since I have to tap the automation icon (once to turn it from orange, to white, followed by a second tap [ and hold] to select `Record')...which is when the audio stops and the recording button (that was orange) is now grey. Everything else in the previously recorded automation track continues to play.





Pongo

  • Senior Member
  • ****
  • Posts: 244
  • Karma: +4/-2
Re: Automation overdub disables playback of a recording
« Reply #3 on: July 30, 2014, 10:28:15 PM »
I will say that for songs where I have managed to record all automation events in one pass (only to then make adjustments to the timing of the event(s)), SLM works great...but for adding additional automation to existing data...it's not so great, for me.


arlo

  • Administrator
  • Senior Member
  • *****
  • Posts: 4605
  • Karma: +107/-3
Re: Automation overdub disables playback of a recording
« Reply #4 on: July 31, 2014, 09:18:43 AM »
I know that the Recording Start/Stop `event' has passed in the existing automation track, when I hear the recording playing, which is when I attempt to record additional automation events!

Do you have the song selection action to start automation tracks enabled when you are doing this? Then that's starting the audio playback, and then when you start recording and the automation track restarts, that's stopping the audio playback. You would need to stop the audio playback, and reset anything else that the previously recorded automation events changed, before you start recording an overdub. Basically, reset the song to the original state. Or you can turn off the song selection action to play automation tracks while you record your overdubs if that's easier.

Pongo

  • Senior Member
  • ****
  • Posts: 244
  • Karma: +4/-2
Re: Automation overdub disables playback of a recording
« Reply #5 on: July 31, 2014, 09:27:49 AM »
Do you have the song selection action to start automation tracks enabled when you are doing this? Then that's starting the audio playback, and then when you start recording and the automation track restarts, that's stopping the audio playback. You would need to stop the audio playback, and reset anything else that the previously recorded automation events changed, before you start recording an overdub. Basically, reset the song to the original state. Or you can turn off the song selection action to play automation tracks while you record your overdubs if that's easier.

Aha! Perhaps that's the secret!

I'll give this a try.

Thanks,

Pongo

  • Senior Member
  • ****
  • Posts: 244
  • Karma: +4/-2
Re: Automation overdub disables playback of a recording
« Reply #6 on: August 01, 2014, 01:10:34 PM »
Works great...except for the event timing drift that you're already aware of from another member's thread.

IMHO, you should update the automation tutorial (not your video) to add this section about overdubbing. Other users may not know how to successfully overdub, if they have enabled a Song Selection Action to play the automation.

Thanks for the help Arlo.
« Last Edit: August 01, 2014, 01:31:15 PM by Pongo »