Before posting, please read: When to use this forum, when to submit a help ticket


Started by base851, September 25, 2014, 08:26:24 AM

Previous topic - Next topic


Hi All,

I have Setlist Maker and I'm having problems getting MIDI preset switching to work with my Axe FX II. I have an iRig MIDI 2 hooked into my iPad with the iRig's MIDI out running to an Axe's MIDI in. The Axe has the MIDI Channel set to 1 in the I/O menu. When I switch songs in Setlist Maker, the iRig's indicator light flashes, so I'm pretty sure the MIDI command is firing, but nothing is changing. I have attached screenshots from the iPad to help you diagnose the problem.

And the first attached image is one of the song settings. The second is one of the MIDI presets. The third is the Audio & MIDI settings.  The fourth is my MIDI Device setting for the Axe FX.

Any advice would be appreciated.



Here are a few things to try:

- Remove the port setting from the MIDI device and the MIDI preset. This shouldn't matter, but removing it simplifies your setup.

- Send the MIDI message by tapping the MIDI icon in the MIDI Presets list, rather than by changing songs. This will isolate the problem to the MIDI setup.

- Try entering your program change values into the program change fields instead of the raw MIDI field. Remember that program numbers are counted from 0 in Set List Maker but might be counted from 1 on the receiving device.


Hey Arlo,

Thanks for the suggestions. I tried them all but didn't have any luck.  :(

I have the same question pending in the Axe FX forums in a thread that mentioned this SLM. That's how I found out about it. I know some people there have gotten it work, and they were suggesting the raw hex approach. That's why I tried it first. The example given was to do a preset switch... in hex they gave C0 00 00, which was to do a program switch to Bank 1, Preset 1, so I'm pretty sure the Axe is 0-indexed.

Here is the thread...

I tried the suggestion to use the program change and tried both 000 ___ 000 as well as 0 ___ 0, and no luck.

As before, the light on the iRig is flashing so I'm pretty sure a MIDI command is going out (I used the MIDI preset directly this time). I also know that MIDI works on the Axe because previously I was using a Pod HD500 as a MIDI footswitch.

Any other ideas?


Oh gawd...

I reseated the MIDI cable and *poof* it works. Time to play around with it.

Great piece of software!  :D


Good, because I was out of ideas!