Before posting, please read: When to use this forum, when to submit a help ticket

Author Topic: Frequent "hangs" since the last two updates or so  (Read 5677 times)

Sander

  • Senior Member
  • ****
  • Posts: 66
  • Karma: +0/-0
Frequent "hangs" since the last two updates or so
« on: March 28, 2015, 01:46:40 PM »
Hi everybody,

Am I the only one experiencing frequent "hangs" since the last few versions? It seems to happen mainly when I have my keyboard (a Korg Kronos) midi'd up for patch selection purposes. It's hard to be specific, but basically I'll be playing for a while and I'll try to select another song from Setlist Maker and nothing happens. The program stops responding altogether, like I'm tapping away at a still image. Sometimes it suddenly comes back after a while, processing all my taps in quick succession. But it may take up to a minute to do so. Usually I try to close it by double tapping my stop button and flipping the app up. When I reopen the app, it's usually in the same spot again and it will take more time for it to get back to normal.

Obviously I can't have this happen. I was wondering if there may be anything happening with the midi buffers or something. My iPad is hooked up to my Kronos over USB (which is class compliant for both audio and midi). I only need to send patch changes out of SLM, and occasionally an audio click. Both of these things work fine. I never had these issues before. I'm still on iOS 7 because I have an iPad 4 and have heard about several issues with iOS 8 and audio/midi apps in general.

arlo

  • Administrator
  • Senior Member
  • *****
  • Posts: 4284
  • Karma: +104/-3
Re: Frequent "hangs" since the last two updates or so
« Reply #1 on: March 28, 2015, 06:23:30 PM »
FWIW, I haven't heard of this from anyone else. It would be good if you could narrow it down to any particular functions, like determine for sure if it is related to MIDI or not. I'd also be curious to find out if the problem happens with any other apps. Finally, did you already try a device restart?

Sander

  • Senior Member
  • ****
  • Posts: 66
  • Karma: +0/-0
Re: Frequent "hangs" since the last two updates or so
« Reply #2 on: March 29, 2015, 12:54:55 AM »
I've definitely restarted since it happened, but I can't say for sure that I have since the last update. i'll try. I realize that the issue sounds way too vague for you to know where to look in the code, I was hoping you had heard some similar or more specific reports. It seems to be only Setlist Maker. Is there any way to make sure Setlist Maker ignores ALL incoming midi, including clock etc.? That way at least I could make sure it's not getting confused from that.

Yesterday I worked for a while adding new songs and everything was fine apart from a few crashes (most often when I create a new song and am entering info like chords, sorry to derail here but it's really quite often).

Yet earlier that day I was in a rehearsal and presentation with my band and had SLM hooked up to my Kronos. I would be playing for a few minutes, leaving it alone for a few minutes, playing again and then upon trying to switch songs notice everything is stuck. I'm just guessing it may be midi causing the issue here because it happened to me once with two other synths that didn't get along. But it seems a good place to start the elimination process.

arlo

  • Administrator
  • Senior Member
  • *****
  • Posts: 4284
  • Karma: +104/-3
Re: Frequent "hangs" since the last two updates or so
« Reply #3 on: March 29, 2015, 01:33:54 PM »
I've definitely restarted since it happened, but I can't say for sure that I have since the last update. i'll try. I realize that the issue sounds way too vague for you to know where to look in the code, I was hoping you had heard some similar or more specific reports. It seems to be only Setlist Maker. Is there any way to make sure Setlist Maker ignores ALL incoming midi, including clock etc.? That way at least I could make sure it's not getting confused from that.

One way is to disconnect your hardware MIDI interface and force-quit all other apps. Another way is to look at the MIDI icon in the top toolbar ... if it's not blinking, Set List Maker isn't receiving (or sending) MIDI.

Sander

  • Senior Member
  • ****
  • Posts: 66
  • Karma: +0/-0
Re: Frequent "hangs" since the last two updates or so
« Reply #4 on: March 31, 2015, 07:11:45 AM »
I'll try that, thanks. Will the icon also blink upon receiving controller data and clock?
Is there any way to "block" incoming midi?

arlo

  • Administrator
  • Senior Member
  • *****
  • Posts: 4284
  • Karma: +104/-3
Re: Frequent "hangs" since the last two updates or so
« Reply #5 on: March 31, 2015, 08:22:27 AM »
Yes, it will blink when receiving any MIDI data.

You can block incoming data by setting a specific input channel and/or port on the Settings > Remote Control page, and then the app will ignore any data that doesn't come from that port or match that channel (MIDI messages that aren't channel-specific will pass through the channel filter).

Sander

  • Senior Member
  • ****
  • Posts: 66
  • Karma: +0/-0
Re: Frequent "hangs" since the last two updates or so
« Reply #6 on: March 31, 2015, 09:23:31 AM »
Ok, thanks! I'll experiment some more.

arlo

  • Administrator
  • Senior Member
  • *****
  • Posts: 4284
  • Karma: +104/-3
Re: Frequent "hangs" since the last two updates or so
« Reply #7 on: April 16, 2015, 05:27:29 PM »
When this happens, are you connected to a wi-fi network that doesn't have an Internet connection? If so, that might be your problem ... the app might be hanging up while looking for the network. On iOS 8, that happens in the background so you generally wouldn't notice it.

If that's the problem, you could switch to Airplane Mode if you don't need the wi-fi network, or turn off auto-sync to avoid triggering any syncing during your performance, or update your device to iOS 8.

GhostNote

  • Newbie
  • **
  • Posts: 1
  • Karma: +0/-0
Re: Frequent "hangs" since the last two updates or so
« Reply #8 on: April 20, 2015, 10:05:17 AM »
I'm having the same problem that Sander described. I seem to have worked around the problem by disabling Auto-Sync in this database.

It only started after the last app update, and it happened a few hours into our band practice last week. Up until that time, everything was fine (I've been using SLM almost a year).

I was sending MIDI at that time, but then I disconnected from MIDI, tried restarting the app, and restarting the iPad, and still had the same extremely sluggish responsiveness, but only with SLM, no other apps.  Days later, still the same problem, and I still was not connected to my MIDI interface.

Just this morning, I tried turning off Auto-Sync on this database, and so far, it seems to have completely fixed the problem. Interestingly, I have 4 databases, two of which I use more than the others, and this problem seems to be unique only to one of the databases, which is not my largest database, at least in terms of song count (it has 151 songs). I have Auto-Sync turned on for another database (with 244 songs), and I don't have any issue (so far). I've always had Auto-Sync enabled for all of my databases, and never had any issue until last week.

I'm running the latest SLM 4.1.5, on an iPad 2 with iOS version 7.1.2. I have 33GB free on a 64GB device.

Sander

  • Senior Member
  • ****
  • Posts: 66
  • Karma: +0/-0
Re: Frequent "hangs" since the last two updates or so
« Reply #9 on: May 03, 2015, 05:21:19 AM »
When this happens, are you connected to a wi-fi network that doesn't have an Internet connection? If so, that might be your problem ... the app might be hanging up while looking for the network. On iOS 8, that happens in the background so you generally wouldn't notice it.

If that's the problem, you could switch to Airplane Mode if you don't need the wi-fi network, or turn off auto-sync to avoid triggering any syncing during your performance, or update your device to iOS 8.
Thanks for this suggestion, I haven't been to the forum in two weeks and was just coming back to say something to this effect. First off, I'm still on iOS7. I heard many initial bad reports on 8 and I didn't want to break a working system. Everything has been fine until a recent-ish update of Setlist Maker... Maybe January or so? I didn't gig much in Jan/Feb.

Secondly, yes I am connected to a network with no Internet. This is on purpose - I use the GLD OneMix app to handle my monitor mix. The engineer has an Allen & Heath GLD digital desk hooked up to a router and me and some bandmates use that wifi network with the iOS app to make our own in ear mix. So Airplane Mode isn't really an option.

I did try turning of DB sync but it didn't seem to make a difference. I only tried turning off DB sync for that specific database though. I have a few that are set up to sync, I don't know if SLM does all of them in the background even if they're not open/in use.

Now that the problem is identified, I hope something can be done in an update!

Interestingly, SLM seems to not hang if I completely close the GLD app. Or if it does, much much less. It hangs pretty reliably otherwise.  Sorry for the red herring with the midi, it seemed a likely cause to me. I've never had two completely unrelated apps interact like this before.

arlo

  • Administrator
  • Senior Member
  • *****
  • Posts: 4284
  • Karma: +104/-3
Re: Frequent "hangs" since the last two updates or so
« Reply #10 on: May 04, 2015, 08:03:36 AM »
I'm not seeing that the problem is identified, if you say that quitting the other app significantly reduces but doesn't eliminate the hanging, and that turning off auto-sync doesn't affect the hanging. But I would further test the idea of the wi-fi being the problem by turning on Airplane Mode. I understand that you can't do a gig that way, but you should be able to test that way to see if it eliminates the problem.

If you still have the hanging problem, but occasionally, then the next step would be to identify what action triggers that ... what button you press in the app, or what activity the other app is doing, etc.

Regarding iOS 8, it's very smart to wait for two or three software updates after a big OS version is released ... but we've already had four updates to iOS 8 and pretty soon we'll be looking at iOS 9, so I think you're past the point where staying with iOS 7 is helpful. That said, the only thing I know that will change when updating from iOS 7 to iOS 8 is that Set List Maker will be able to multi-task any sync operations, so it would be worth establishing that that is the problem first. I generally don't update any software unless I have a specific reason to do so.

Sander

  • Senior Member
  • ****
  • Posts: 66
  • Karma: +0/-0
Re: Frequent "hangs" since the last two updates or so
« Reply #11 on: May 04, 2015, 09:24:41 AM »
Right, so then my main question would  be, does SLM sync databases that aren't currently open? I.e. if I disable autosync on my gigging database, should that stop SLM from syncing at all while I'm using that database?

The other app is constantly updating the level meters over wifi but it never hangs when using it by itself. So I don't understand why it should be affecting SLM at all. It doesn't affect ForScore or Avid Scorch for instance, both of which I've used on gigs.

As for action, I'm generally not doing anything at all, not even touching the iPad. I'll be looking at SLM, playing my keyboard and then only notice it has hung when I try to select the next song or something. If the metronome is running, I can see it hang but otherwise there is no indication. That's why I thought it might be related to the midi I'm outputting but even removing the cable altogether doesn't change anything.

arlo

  • Administrator
  • Senior Member
  • *****
  • Posts: 4284
  • Karma: +104/-3
Re: Frequent "hangs" since the last two updates or so
« Reply #12 on: May 04, 2015, 09:59:58 AM »
Quote
Right, so then my main question would  be, does SLM sync databases that aren't currently open?

No.

Quote
I.e. if I disable autosync on my gigging database, should that stop SLM from syncing at all while I'm using that database?

Yes.

Quote
As for action, I'm generally not doing anything at all, not even touching the iPad. I'll be looking at SLM, playing my keyboard and then only notice it has hung when I try to select the next song or something. If the metronome is running, I can see it hang but otherwise there is no indication. That's why I thought it might be related to the midi I'm outputting but even removing the cable altogether doesn't change anything.

I can't think of any reason the app would hang without any action requested of it. Does the problem ever occur when you do have an Internet connection, and does it ever occur in Airplane Mode? That would answer definitively whether the problem is related to the unconnected wi-fi network or if we need more ideas.

Sander

  • Senior Member
  • ****
  • Posts: 66
  • Karma: +0/-0
Re: Frequent "hangs" since the last two updates or so
« Reply #13 on: May 04, 2015, 11:01:56 AM »
It's hard to prove a negative, but it has never hung while I've been entering songs or making lists at home. I have a working internet connection here of course. I also have the GLD app open in the background at home sometimes, simply because iOS leaves it there unless you explicitly close it. Although obviously when I'm home it stays in its login screen because I can't login to a desk that's not there.

I'm pretty confident it still happens when I've disabled AutoSync, I did try that and even considered it might have to do with internet-less wifi networks but I dismissed the idea when it still hung. At this point I'm convinced enough that it's related to wifi/internet that it doesn't make much sense to try Airplane mode. I'm sure it will work perfectly in airplane mode, as it works perfectly at home. I thought it might be the midi thing because generally gig time is the only time when it's connected to my Kronos directly. But I couldn't reproduce it at home even when I tried.

So either it's the actual wifi connection that's still being called for some reason or SLM is being affected by the GLD app in the background. I will try disabling autosync again. Perhaps I'm misremembering. 



arlo

  • Administrator
  • Senior Member
  • *****
  • Posts: 4284
  • Karma: +104/-3
Re: Frequent "hangs" since the last two updates or so
« Reply #14 on: May 04, 2015, 11:44:14 AM »
With auto-sync turned off, syncing (and Internet use) should only occur if you sync manually. But if the app still hangs, you can watch the sync button in the top toolbar to see if it is blinks at all and that will tell us if the app is indeed trying to do a sync at that time. The blinking will be irregular on iOS 7 with no Internet connection, but you should see it if it's happening.